xpi не может установить?

71
5

Я создаю пустой проект расширения firefox через eclpse + spket, а затем редактирую install.rdf, как это

 <em:minVersion>1.5</em:minVersion>
<em:maxVersion>33.0.0.*</em:maxVersion>

Я запускаю ant build.xml и создаю *.xpi успешно, но когда я пытаюсь установить его в firefox, он не может быть установлен, просто показано, что "расширение не может быть установлено, возможно, оно сломалось". Моя версия firefox - 32.0, самая новая версия, и я проверил структуру пакета xpi, который соответствует правильному стандарту запроса mozilla. в чем проблема? ТКС

спросил(а) 2014-08-13T06:01:00+04:00 5 лет, 7 месяцев назад
1
Решение
63

Я не думаю, что это не должно приводить к тому, что xpi не будет устанавливаться, но наверняка AMO (addons.mozilla.org) не примет это, так как максимальная версия неприемлема. См. AMO :: Версии приложений для действительных строк, которые вы можете поместить в минимальную и максимальную версию.

После исправления, попробуйте установить xpi, если это работает, действительно здорово!

После прочтения ссылки, указанной выше, ваша максимальная версия должна быть 33.*

ответил(а) 2014-08-13T14:49:00+04:00 5 лет, 7 месяцев назад
Ваш ответ
Введите минимум 50 символов
Чтобы , пожалуйста,
Выберите тему жалобы:

Другая проблема