Tools: overrideLibrary не работает

107
10

Я пытаюсь переопределить minSDK библиотеки, которую я использую в моем файле gradle. Ниже приведено сообщение об ошибке


Error:Execution failed for task ':app:processDebugManifest'.
> Manifest merger failed : uses-sdk:minSdkVersion 10 cannot be smaller than version 13 declared in library [com.intuit.sdp:sdp-android:1.0.2] C:\Users\{User_Name}\{App_Name}\app\build\intermediates\exploded-aar\com.intuit.sdp\sdp-android\1.0.2\AndroidManifest.xml
Suggestion: use tools:overrideLibrary="com.intuit.sdp" to force usage

Быстрый google сказал мне использовать overrideLibrary в Mainfest. поэтому я добавляю следующие строки в свой AndroidManifest.xml


<uses-sdk
android:minSdkVersion="10"
tools:overrideLibrary="com.intuit.sdp" />

Затем я очищаю и перестраиваю проект, но он все еще показывает мне ту же самую ошибку, что и раньше.

спросил(а) 2015-10-02T14:15:00+03:00 5 лет назад
0
Ваш ответ
Введите минимум 50 символов
Чтобы , пожалуйста,
Выберите тему жалобы:

Другая проблема