SVN не может обновлять или обновлять рабочую копию - ошибки E155036 & E155016

58
5

Во-первых, я признаю, что SVN действительно меня смущает. Новичок!

У меня есть плагин Wordpress, над которым я работал, и хочу опубликовать обновление. В прошлом это прошло гладко, но прошло много времени с тех пор, как я сделал с ним что-то, и мне пришлось обновить свой SVN Client (на Mac Mavericks), и теперь я на 1.8.11.

Если я попытаюсь обновить свой проект, я получаю сообщение об ошибке, которое мне нужно обновить мою рабочую копию:

svn: E155036: Please see the 'svn upgrade' command
svn: E155036: The working copy at '/path/to/file'
is too old (format 10) to work with client version '1.8.11 (r1643975)' (expects format 31). You need to upgrade the working copy first.

Но если я попытаюсь обновить (как мне подсказывает), процесс закроется, и я также получу ошибку:

svn: E155016: Insufficient NODES rows for '/path/to/file/.svn/tmp/wcng/trunk/css/images'

Я пытаюсь найти способ использовать svnX и Terminal, и я не понимаю, как это сделать. Любые предложения приветствуются...

Мэтью

спросил(а) 2015-02-11T23:02:00+03:00 5 лет, 8 месяцев назад
1
Решение
90

Для любых будущих искателей, таких как я:

Эта ошибка может быть вызвана старыми внешними SVN файлами возврата в вашей рабочей копии, такими как .svn-revert или .svn/dir-prop-revert. Просто удалите такие файлы (они не используются ни для чего), а затем вы сможете завершить svn upgrade !

Взгляните на официальный отчет об ошибке для получения более подробной информации: https://issues.apache.org/jira/browse/SVN-4043

ответил(а) 2018-01-10T08:13:00+03:00 2 года, 9 месяцев назад
Ваш ответ
Введите минимум 50 символов
Чтобы , пожалуйста,
Выберите тему жалобы:

Другая проблема