Совместимость с NServiceBus v3.3 и v4.0

65
5

У меня есть процесс NServiceBus с самостоятельным размещением (IIS), который запускает NServiceBus 3.3.3.

Я собираюсь создать еще один процесс в IIS (на том же компьютере), который будет принимать сообщения из версии 3.3.3. Я хотел бы сделать новую версию версии 4.0.4 (последняя версия).

Кто-нибудь знает, будут ли проблемы с совместимостью отправляться с 3.3.3 до 4.0.4?

спросил(а) 2021-01-19T18:01:00+03:00 9 месяцев, 1 неделя назад
1
Решение
79

Не должно быть никаких проблем.
Версия N <-> N + 1 всегда обратно совместима с проводом.

Если вы обнаружите какие-либо проблемы, пожалуйста, поднимите его в Github, и мы это исправим!

ответил(а) 2021-01-19T18:01:00+03:00 9 месяцев, 1 неделя назад
Ваш ответ
Введите минимум 50 символов
Чтобы , пожалуйста,
Выберите тему жалобы:

Другая проблема