require (file.js) дает error.mean версии 0.1.2

126
11

я попробовал нормальный запрос для повторного использования кода, я получаю эту ошибку

Не удается найти модуль. /app/models/test.js '

// app/models/test.js

exports={
unit:['l','kg','ton']
}

//app/controllers/enum.js

var val=require('./app/models/test.js')
exports.all = function(req, res){
res.jsonp(val);
}

я также пробовал module.exports, но не повезло

Структура папок приложения соответствует среднему.

спросил(а) 2021-01-19T18:15:57+03:00 6 месяцев назад
1
Решение
100

нужно написать две точки так:

// app/models/test.js

exports={
unit:['l','kg','ton']
}

//app/controllers/enum.js

var val=require('../models/test.js')
exports.all = function(req, res){
res.jsonp(val);
}

ответил(а) 2021-01-19T18:15:57+03:00 6 месяцев назад
Ваш ответ
Введите минимум 50 символов
Чтобы , пожалуйста,
Выберите тему жалобы:

Другая проблема