Ошибка при подключении PlugUpdate

59
9

В настоящее время я работаю на Mac с Neovim и Vim Plug. Всякий раз, когда я запускаю commend :PlugUpdate, я получаю следующую ошибку:

Error detected while processing function <SNR>2_job_handler:
line 19:
E121: Undefined variable: self

Я также пытался обновить плагины один за другим, и ошибка все еще возникает.

И плагины не обновляются. Я также пытался обновить neovim до последней версии, но ошибка все еще происходит.

Кто-нибудь знает, откуда исходит ошибка?

спросил(а) 2017-07-16T19:43:00+03:00 2 года, 4 месяца назад
1
Решение
70

Оказывается, это был сам Vim Plug.

Мне пришлось запустить :PlugUpgrade для обновления Vim Plug, а затем запустить :PlugInstall чтобы исправить ошибки.

Оставляя это здесь для людей, у которых будет такая же проблема. :)

ответил(а) 2017-07-16T20:15:00+03:00 2 года, 4 месяца назад
Ваш ответ
Введите минимум 50 символов
Чтобы , пожалуйста,
Выберите тему жалобы:

Другая проблема