Невозможно установить плагин vagrant-berkshelf версии 1.3.7 с любой версией Vagrant

59
6

Мой проект команды требует, чтобы я использовал плагин vagrant-berkshelf, в частности версию 1.3.7. Остальные в команде управляют Vagrant 1.3.5, хотя я попытался установить на 1.2.7, 1.3.5 и 1.4.3 все с одинаковой ошибкой.

Выход при установке:

    mentat@odrade:~$ vagrant plugin install vagrant-berkshelf --plugin-version 1.3.7
Installing the 'vagrant-berkshelf --version '1.3.7'' plugin. This can take a few minutes...
/opt/vagrant/embedded/lib/ruby/2.0.0/rubygems/dependency_installer.rb:211:in 'gather_dependencies': Unable to resolve dependencies: ridley requires buff-extensions (~> 0.3); buff-config requires buff-extensions (~> 0.3); varia_model requires buff-extensions (~> 1.0) (Gem::DependencyError)
from /opt/vagrant/embedded/lib/ruby/2.0.0/rubygems/dependency_installer.rb:333:in 'install'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/plugins/commands/plugin/action/install_gem.rb:65:in 'block in call'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/plugins/commands/plugin/gem_helper.rb:42:in 'block in with_environment'
from /opt/vagrant/embedded/lib/ruby/2.0.0/rubygems/user_interaction.rb:40:in 'use_ui'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/plugins/commands/plugin/gem_helper.rb:41:in 'with_environment'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/plugins/commands/plugin/action/install_gem.rb:52:in 'call'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/lib/vagrant/action/warden.rb:34:in 'call'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/plugins/commands/plugin/action/bundler_check.rb:20:in 'call'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/lib/vagrant/action/warden.rb:34:in 'call'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/lib/vagrant/action/builder.rb:116:in 'call'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/lib/vagrant/action/runner.rb:69:in 'block in run'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/lib/vagrant/util/busy.rb:19:in 'busy'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/lib/vagrant/action/runner.rb:69:in 'run'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/plugins/commands/plugin/command/base.rb:17:in 'action'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/plugins/commands/plugin/command/install.rb:27:in 'execute'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/plugins/commands/plugin/command/root.rb:56:in 'execute'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/lib/vagrant/cli.rb:38:in 'execute'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/lib/vagrant/environment.rb:484:in 'cli'
from /opt/vagrant/embedded/gems/gems/vagrant-1.4.3/bin/vagrant:127:in '<top (required)>'
from /opt/vagrant/bin/../embedded/gems/bin/vagrant:23:in 'load'
from /opt/vagrant/bin/../embedded/gems/bin/vagrant:23:in '<main>'

Проблемы с зависимостями связаны с ridley, buff-extensions и buff-config. В настоящее время я использую RVM с Ruby 1.9.3-p448, а список драгоценных камней показывает, что я должен соответствовать этим зависимостям. Если я попытаюсь установить версию плагина vagrant-berkshelf, я получаю другой список проблем с зависимостями (но это спорный вопрос, так как мне нужно будет находиться на 1.3.7).

Есть идеи?

спросил(а) 2014-06-05T07:49:00+04:00 6 лет, 6 месяцев назад
1
Решение
101

Я смог получить эту работу, установив необходимые драгоценные камни:

env GEM_HOME=~/.vagrant.d/gems gem install buff-extensions -v 0.3.0
env GEM_HOME=~/.vagrant.d/gems gem install buff-extensions -v 1.0.0
vagrant plugin install vagrant-berkshelf --plugin-version 1.3.7

Я не закончил тестирование, поэтому не уверен, что во время работы будет конфликт.

--- РЕДАКТИРОВАТЬ ---

Если вы делаете это выше, плагин не загружается.
Вместо этого обязательно установите более старую версию драгоценного камня varia_model. Я предлагаю 0.3.2. Этот камень не требует более поздней версии buff-extensions

env GEM_HOME=~/.vagrant.d/gems gem install varia_model -v 0.3.2
vagrant plugin install vagrant-berkshelf --plugin-version 1.3.7

ответил(а) 2014-06-06T03:50:00+04:00 6 лет, 6 месяцев назад
Ваш ответ
Введите минимум 50 символов
Чтобы , пожалуйста,
Выберите тему жалобы:

Другая проблема