не удалось обновить до Ruby 2.1.4

95
8

В настоящее время Yosemite работает и не может обновиться до ruby 2.1.4, см. Ниже.

Guidos-MacBook-Pro:~ Guido$ rvm install 2.1.4
Searching for binary rubies, this might take some time.
No binary rubies available for: osx/10.10/x86_64/ruby-2.1.4.
Continuing with compilation. Please read 'rvm help mount' to get more information on binary rubies.
Checking requirements for osx_brew.
/usr/local/bin/brew: /usr/local/Library/brew.rb: /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby: bad interpreter: No such file or directory
/usr/local/bin/brew: line 26: /usr/local/Library/brew.rb: Undefined error: 0
ERROR: '/bin' is not writable - it is required for Homebrew, try 'brew doctor' to fix it!
Requirements installation failed with status: 1.

спросил(а) 2015-02-22T23:44:00+03:00 6 лет назад
1
Решение
85

Поэтому, после того как я несколько часов отошел от компьютера и вернулся, я понял, что проблема в том, что Homebrew был сломан после того, как я обновил ОС до Йосемити. Вот ссылка http://ryantvenge.com/2014/09/ruby-homebrea-yosemite/ на решение. Если это не работает, см. Команды ниже.

Чтобы исправить Homebrew:

cd/System/Library/Frameworks/Ruby.framework/Versions
sudo ln -s Текущий 1.8
обновить
sudo rm 1.8

Обновление до ruby 2.1.4:

rvm install 2.1.4
Использование rvm 2.1.4

ответил(а) 2015-02-23T04:48:00+03:00 6 лет назад
Ваш ответ
Введите минимум 50 символов
Чтобы , пожалуйста,
Выберите тему жалобы:

Другая проблема