Какая настройка необходима для компиляции rpy2 в Windows?

126
13

Мне удалось установить rpy2 v2.0.8 из .msi из исходной кузницы, но я бы хотел использовать последнюю версию, которая включает в себя код пакета, т.е. v2.1.9.


Я пытаюсь скомпилировать rpy2 в windows (python 2.6.6).


CL жалуется, потому что LibExtern определяется как extern и как declspec в другом месте.


gcc и c++ также не могут компилироваться без ошибок.


Я предполагаю, что это компилирует ok в unix, и что все, что мне не хватает, это некоторая конфигурация (переменные переменной задачи), так как я не могу поверить, что она была бы выпущена в не компилируемой форме.


Кто-нибудь указывает мне в правильном направлении PLS?


Много спасибо


DM

спросил(а) 2021-01-19T17:31:07+03:00 6 месяцев назад
1
Решение
64

Лучше всего загрузить его из этого сайта. В нем есть все популярные репозитории, которые необходимо скомпилировать для работы. В основном это группа Unofficial Windows Binaries для пакетов расширения Python Кристофа Гольке в Лаборатории флуоресцентной динамики, Калифорнийский университет, Ирвин.


Я дал вам ссылку на последнюю версию rpy2, и есть версии для каждого типа Python. Обратите внимание, что вам понадобится R. Загрузите версию для 2.7, она должна работать на 2.6.6, но если это не так, обновите свой Python 2.7.5.

Однако, если вы по-прежнему заинтересованы в компиляции двоичных файлов, тогда вам нужно будет дать мне сообщения об ошибках и трассировки, так как в противном случае вы не можете точно знать, каковы ваши точные проблемы.

ответил(а) 2021-01-19T17:31:07+03:00 6 месяцев назад
Ваш ответ
Введите минимум 50 символов
Чтобы , пожалуйста,
Выберите тему жалобы:

Другая проблема