FOSUserBundle для Symfony 2.4.3

108
15

Я хочу начать новый проект на symfony 2.4.3, и мне нужна функциональность fosuserbundle. Моя проблема: на их github (https://github.com/FriendsOfSymfony/FOSUserBundle) в документации они рекомендуют 2.1.x.

Здесь пользователь говорит, что вы должны установить fosuserbundle вручную, но этот вопрос предназначен для symfony 2.3.

Могу ли я использовать пакет в моей версии symfony? Если да, могу ли я установить его с помощью композитора? Если нет, есть ли подобные связки, которые я могу использовать вместо этого?

заранее спасибо

спросил(а) 2014-05-22T20:40:00+04:00 6 лет, 5 месяцев назад
1
Решение
72

Для этой версии пакета требуется Symfony 2. 1+. Если вы используете Symfony 2.0.x, используйте версии 1.2.x пакета.

Из своих документов. 2. 1+ означает, 2.1, 2.2, 2.3, 2.4,... 2.n Итак, 2.3 совершенно справедливо.

Кроме того, Composer обрабатывает зависимости для вас, поэтому просто требуйте его и запустите composer update, если версия Symfony не поддерживается, команда не работает, и вы знаете, что она не поддерживает вашу текущую версию, если она преуспевает, все работает отлично.

ответил(а) 2014-05-22T23:39:00+04:00 6 лет, 5 месяцев назад
Ваш ответ
Введите минимум 50 символов
Чтобы , пожалуйста,
Выберите тему жалобы:

Другая проблема