cvc-complex-type.2.4.c: Соответствующий шаблон является строгим, но для элемента 'oxm: jaxb2-marshaller' не найдено объявления.

70
8

У меня есть код в файле config.xml

 <beans:beans xmlns="http://www.springframework.org/schema"
xmlns:oxm="http://www.springframework.org/schema/oxm"
xsi:schemaLocation=
" http://www.springframework.org/schema/oxm http://www.springframework.org/schema/oxm/spring-oxm-3.1.xsd

<beans:oxm:jaxb2-marshaller id="SampleTestmapper"
contextPath="com.sample.base.Testing001"/>

Выше кода дает мне ошибку, говоря, что соответствующий шаблон является строгим, но для элемента 'oxm: jaxb2-marshaller' не найдено объявления.

Я объявил правильную версию oxm, которая является 3.1.xsd в соответствии с моей версией весны. И у меня также есть файл jar в классе. Любая идея, почему я все еще получаю ошибку?

Примечание: в моем pom.xml это то, как я добавил зависимость

<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-oxm</artifactId>
</dependency>

спросил(а) 2015-06-16T17:07:00+03:00 5 лет, 3 месяца назад
0
Ваш ответ
Введите минимум 50 символов
Чтобы , пожалуйста,
Выберите тему жалобы:

Другая проблема