Composer requrie ext-redis

59
9

Я пытаюсь установить расширение phpredis как требование для моего приложения. Вот мой композитор.json:

"ext-redis": ">=2.2.7"

А также попробовали эти варианты: "^2.2.7", 2.2.7@dev

Но все время я получаю ошибку ниже:

  Problem 1
- The requested PHP extension ext-redis >=2.2.7 has the wrong version (2.2.8-devphp7) installed. Install or enable PHP redis extension.

мое требование >=2.2.7 не складывается с фактической версией 2.2.8-devphp7 которая, похоже, вписывается в это ограничение версии?

спросил(а) 2016-04-22T15:55:00+03:00 4 года, 5 месяцев назад
1
Решение
57

Версия 2.2.8-devphp7 просто не поддерживается и разрешает 0:

Мы просто не можем его разобрать. Это означает, что установленная версия заканчивается непризнанной, и поэтому она по умолчанию равна 0

и никогда не будет поддерживаться:

Вы должны относиться к этой версии как 0 и позволить его на обескуражен * ограничение.

Обновление: теперь поддерживается с композитора-1.1.1

ответил(а) 2016-05-04T21:22:00+03:00 4 года, 4 месяца назад
Ваш ответ
Введите минимум 50 символов
Чтобы , пожалуйста,
Выберите тему жалобы:

Другая проблема