Composer-Php – вопросы и ответы

-4
голоса
2
ответа
Я пишу этот код: index.php: (Мой индекс) <?php namespace com; $loader = require __DIR__ . '/../vendor/autoload.php'; $loader->add(__NAMESPACE__, __DIR__ . '/../../'); $loader->register(); ...
3 месяца, 1 неделя назад EqWey Ace
116
голосов
2
ответа
У меня есть приложение CodeIgniter. Я пытался настроить его для работы с Facebook ADS SDK ( https://github.com/facebook/facebook-php-ads-sdk ). Я хочу использовать простые строки в моем контроллере...
3 месяца, 1 неделя назад NeuTronas
-4
голоса
1
ответ
Развертывание приложения Symfony 4 в Google App Engine (Flex) с развертыванием приложения gcloud. Сборка не выполняется после установки зависимостей: Step #1: Executing script cache:clear [OK] Step...
3 месяца, 1 неделя назад TimothyAURA
62
голоса
1
ответ
Я делаю свой собственный пакет Composer для образовательных целей. Это просто расширенный пакет Laravel с уже установленными библиотеками. Я загрузил в GitHub: jorgeanzola/laravel Я отправил его в ...
3 месяца, 1 неделя назад Jorge Anzola
62
голоса
1
ответ
Есть ли способ использовать Composer, чтобы указать, что библиотека C является зависимостью, и установить ее соответствующим образом? Проект должен использовать php-postal , который зависит от дост...
3 месяца, 1 неделя назад AdamTheHutt
140
голосов
1
ответ
Я запускаю свой php в кли под моим пользователем. Я установил композитор и autoloader.php. В папках поставщиков и файла были загружены (autoload.php aws, bin, composer, guzzlehttp, mtdowling и psr)...
3 месяца, 1 неделя назад JSChasle
63
голоса
1
ответ
В проекте Symfony 2.3 я хочу установить JQuery UI с помощью Composer. Я нашел components/jqueryui пакета components/jqueryui на packagist.com Проект также использует BraincraftedBootstrapBundle, ко...
3 месяца, 1 неделя назад Max Damage
88
голосов
1
ответ
Я пишу некоторый код (слой абстракции базы данных, который будет использоваться в других моих модулях кода), который я хотел бы выпустить как отдельный модуль, который может быть включен в проект с...
3 месяца, 1 неделя назад Danack
106
голосов
2
ответа
Я установил пакет phpoffice/phpexcel через композитор. В любом случае автозагрузка не работает. Я пробовал каждую комбинацию пространства имен, чтобы вызвать класс, но он не существует: PHP Fatal e...
3 месяца, 1 неделя назад Benedikt
107
голосов
1
ответ
Я предполагаю, что это нужно сделать по-другому, так как оно зависит от пакета, а указания после того, как я его установил (не говорит мне, как) добавить его в качестве поставщика услуг, например: ...
3 месяца, 1 неделя назад Mike T
75
голосов
2
ответа
Я работаю на Windows-машине. Я установил WT-NMP, и я пытаюсь установить composer.phar. Неважно, из какой папки я запускаю этот php -r "eval('?>'.file_get_contents('https://getcomposer.org/instal...
3 месяца, 1 неделя назад user3259692
97
голосов
1
ответ
Введение Я никогда раньше не работал с каркасом (Zend, CakePHP и т.д.) и, наконец, решил сесть и изучить его. Я начинаю с Laravel, потому что код выглядит довольно и в отличие от некоторых других ф...
3 месяца, 1 неделя назад stevendesu
124
голоса
1
ответ
Я прочитал в документации AWS Elastic Beanstalk, что вы можете просто включить файл composer.json в корень вашего пакета, и он установит приложение и его зависимости: http://docs.aws.amazon.com/ela...
3 месяца, 1 неделя назад Amy Neville
62
голоса
2
ответа
У меня есть проект, который я пытаюсь запустить, но я получаю следующую ошибку: PHP Fatal error: Class 'Dotenv' not found in `/home/maras/Documents/eCodile/debtorcare/server/bootstrap/app.php on li...
3 месяца, 1 неделя назад Marek Czyż
129
голосов
3
ответа
У меня есть приложение с зависимостями Composer, которые я хочу развернуть в контейнер Elastic Beanstalk. Однако мой файл composer.json не находится в корневой папке проекта. Мой корень проекта име...
3 месяца, 1 неделя назад Adrian Walls
-8
голосов
1
ответ
У меня есть композитор, и я могу использовать laravel new ProjectName команду для создания нового проекта. Однако для этого требуется активное подключение к Интернету. Мне также нужно иметь возможн...
3 месяца, 1 неделя назад lord AJ
150
голосов
2
ответа
Я следил за официальной документацией когда я запускаю обновление для компоновщика, у меня есть эта ошибка: Ваши требования не могут быть разрешены к устанавливаемому набору пакетов. Problem 1 - do...
3 месяца, 1 неделя назад Sekai
87
голосов
1
ответ
У меня возникла большая проблема после обновления композитора, Acctualy Я работаю с электронной коммерцией sylius на symfony2 (2.8.3). И несколько мгновений назад я сделал обновление для композитор...
3 месяца, 1 неделя назад user4910881
-4
голоса
1
ответ
У меня возникают проблемы с автозагрузкой композитора psr-4. У меня есть структура проекта, которая выглядит так Project - src/ - - Utils/ - - - ID/ - - - - IDInterface.php - - - - ID.php - tests/ ...
3 месяца, 1 неделя назад PatrickL
282
голоса
7
ответов
Я пытаюсь установить Laravel Framework на Windows с помощью метода установщика Laravel. В документации я нашел следующее: Сначала загрузите установщик Laravel с помощью Composer. Убедись в поместит...
3 месяца, 1 неделя назад Markus Hofmann
159
голосов
4
ответа
У меня есть пакет пакетов на Gitlab моей компании. Я хочу запросить определенную версию этих пакетов, но каждый раз, когда я пытаюсь, композитор загружает последнюю фиксацию ведущей ветки. composer...
3 месяца, 1 неделя назад Airmanbzh
62
голоса
1
ответ
Я пытаюсь запустить composer install и я получаю массу ошибок. Что они имеют в виду? composer install Loading composer repositories with package information Updating dependencies (including require...
3 месяца, 1 неделя назад Austin
63
голоса
1
ответ
При установке composer-setup.exe возникает следующая ошибка: Connection Error [ERR_CONNECTION]: Unable to connect to getcomposer.org Proxy http://proxy.mycompany.com:1234 [from Internet Settings] f...
3 месяца, 1 неделя назад DaraRamu
76
голосов
2
ответа
Прежде всего, я понимаю, что это может быть возможный дубликат, но я посмотрел на другой поток, и это не решило мою проблему. В основном я пытаюсь установить Zend Framework 2 и пытаюсь выполнить сл...
3 месяца, 1 неделя назад Ciaran
77
голосов
2
ответа
У меня очень простой конфигурационный файл .travis.yml в ветки с именем "3.0": language: php php: - 5.3 - 5.4 branches: only: - 3.0 before_script: - composer install --dev для
3 месяца, 1 неделя назад Naoise Golden
62
голоса
4
ответа
Я попытался обновить laravel/laravel с 5.3 до 5.4 , и для этого я изменил composer.json на это: { "name" : "laravel/laravel", "description" : "The Laravel Framework.", "keywords" : [ "framework", "...
3 месяца, 1 неделя назад ratm
63
голоса
2
ответа
Неустранимая ошибка: Class 'GuzzleHttp\Client' не найден в ConvergeApi.php в строке 123 Загрузите и установите код из https://github.com/markroland/converge-api-php CentOS 7 PHP 5.4.16 (cli) (постр...
3 месяца, 1 неделя назад Brian Erickson
77
голосов
1
ответ
Может ли кто-нибудь сказать мне, какие советы необходимы для перемещения проекта laravel из окон в linux? Я установил новый проект на linux и скопировал файлы отдельно, но он говорит, что не может ...
3 месяца, 1 неделя назад Akmal Arzhang
76
голосов
2
ответа
Я пытаюсь заставить композитор работать исключительно с целью обновления моих файлов куки-купе (поскольку они недостаточно некомпетентны, чтобы сделать это единственным способом загрузки источника ...
3 месяца, 1 неделя назад Jptalon
76
голосов
1
ответ
Резюме. Мой простой сайт теперь успешно общается с Google Spreadsheets, но неудобство добавления этого API Google Spreadsheets заключается в том, что развертывание моего веб-сайта (через deployhq.c...
3 месяца, 1 неделя назад Ryan
115
голосов
2
ответа
У меня есть основной вопрос при запуске Composer в контейнере Docker. Можно ли запустить composer в качестве пользователя root внутри контейнера? Я сбиваю с толку, что владельцем созданных файлов (...
3 месяца, 1 неделя назад klay
87
голосов
1
ответ
Мне пришлось изменить пакет поставщика ( avatarguru/mustache-l5 ), который не был совместим с последней версией Laravel 5 (dev). Но теперь, когда я делаю composer status в корневом каталоге проекта...
3 месяца, 1 неделя назад artnikpro
-4
голоса
1
ответ
Я получаю следующую ошибку: Неустранимая ошибка: Class 'Controller\Error' не найден в /var/sites/t/websitename/app/lib/Loader.php в строке 36 Это содержимое файла: <?php namespace Lib; use Contr...
3 месяца, 1 неделя назад Neekoy
63
голоса
1
ответ
Когда я расширяю класс, который живет на одном уровне с каталогом, он работает нормально, но когда расширяющийся класс живет на уровне подкаталога с дополнительным каталогом, он этого не делает. Вс...
3 месяца, 1 неделя назад Bluesail20
62
голоса
1
ответ
Недавно я запустил один проект и хочу использовать elasticsearch . Но когда я хочу установить guzzle для PHP через composer , я получаю следующую ошибку. Я понятия не имею, что это за ошибка. Моим ...
3 месяца, 1 неделя назад dzona
77
голосов
1
ответ
Я создал очень простой проект Symfony (3.4), только с одним api, который печатает статический json. Когда я запускаю этот api в первый раз, все работает нормально, но со второго раза я получил эту ...
3 месяца, 1 неделя назад user2540463
367
голосов
1
ответ
Я выполнил эту команду для установки по всему миру PHPUnit: composer global require 'phpunit/phpunit=3.7.*' Теперь я хочу удалить глобально PHPUnit. Любые идеи?
3 месяца, 1 неделя назад winkster
98
голосов
1
ответ
Я создал свой собственный базовый проект, который я устанавливаю в своих проектах с помощью Composer. Это gitrepository, хранящийся на Github. Затем я создаю релизы и нажимаю их на Packagist. Я мог...
3 месяца, 1 неделя назад Dieter Pollier
97
голосов
1
ответ
Я новичок в blockchain. У кого-нибудь есть документ на языке моделирования гиперссылок. Я не знаю, как это написать? Спасибо
3 месяца, 1 неделя назад Hitesh
Чтобы , пожалуйста,
Выберите тему жалобы:

Другая проблема