Будет ли SSDT-BI работать с SQL Server 2008 R2?

77
6

Может кто-нибудь сказать мне, будут ли пакеты SSIS, разработанные в Visual Studio 2012 или 2013, работать на сервере 2008r2 или нет?

Если да, нужно ли устанавливать другое программное обеспечение на сервере 2008r2?

Развертывание здесь не вызывает беспокойства. Я просто хочу запускать пакеты на сервере 2008r2 через работу агента sql

Пожалуйста помоги.

спросил(а) 2016-01-09T09:06:00+03:00 5 лет, 6 месяцев назад
1
Решение
100

Нет. Обратная совместимость не является вариантом. Пакет, построенный в 2014 году, не будет запущен в 2012 году. Пакет 2012 года не будет запущен в 2008 году, а пакет 2008 года не будет запущен в 2005 году.

Тем не менее, передовая совместимость существует, поэтому пакет 2005 года будет запущен в 2008 году. 2008 год будет запущен в 2012, 2012 годах в 2014 году.

Хотя я не думаю, что это ваш сценарий, если у вас есть пакеты SSIS 2012/2014, развернутые на сервере 2012/2014, вы можете запустить их из задачи сервера SQL Server 2008. Это просто вопрос написания catalog.create_execution и catalog.start_execution BOL

Имея этот SQL-скрипт, добавьте задачу шага задания SQL и укажите контекст на ваш сервер 2012/2014.

ответил(а) 2016-01-10T20:00:00+03:00 5 лет, 6 месяцев назад
64

MSDN на https://msdn.microsoft.com/en-us/library/mt204009.aspx содержит обзор всех поддерживаемых комбинаций версий VS/SQLServer.

В принципе, для разработки SSIS SQLServer2008R2 вам понадобятся BIDS (от установки SQLServer).

Инструменты VS2012/VS2013 поддерживают только SSIS SQLServer2012/2014.


Для VS2015 предварительный выпуск Februari средств SSDT-BI предназначен для поддержки разработки нескольких целевых пакетов SSIS (но только для SQLServer2012-2016, не 2008R2), см. Также в комментариях по адресу http://blogs.msdn.com/б /SSDT/архив /2015/12/16/SQL-Server-данных-инструменты предпросмотр-обновление-для-декабря-2015.aspx

Обратите внимание, что есть также что-то, называемое BIML, которое может генерировать пакеты SSIS для разных версий SQLServer (включая 2008R2) из того же исходного кода, поэтому вы можете использовать VS2012/VS2013 с BIDSHelper, а затем в качестве последнего шага могут быть созданы пакеты для SQLServer2008R2,

ответил(а) 2016-01-16T15:04:00+03:00 5 лет, 6 месяцев назад
Ваш ответ
Введите минимум 50 символов
Чтобы , пожалуйста,
Выберите тему жалобы:

Другая проблема