Android-Gradle – вопросы и ответы

71
голос
2
ответа
Большинство разработчиков Android должны получить сообщение от Google об обновлении приложений для поддержки 64-битной архитектуры к августу 2019 года. Подробные инструкции приведены здесь: Убедите...
5 месяцев, 4 недели назад user846316
58
голосов
1
ответ
Когда я пытался синхронизировать мой проект, все библиотеки возвращают код ошибки 400. например: Error:A problem occurred configuring project ':app'. Could not resolve all files for configuration '...
6 месяцев назад docbigolo
120
голосов
3
ответа
Я знаю, что на этом уже много разных потоков, но ни одного исправления не работает, поэтому я решил, что у меня должна быть уникальная проблема или сделать глупую ошибку, которую может указать кто-...
6 месяцев назад Harris Douglas
89
голосов
2
ответа
Новая установка Android SDK и Android Studio. Совершенно новый проект, буквально никаких изменений в каком-либо файле в проекте. Работает AVD, работает 4.4.3 (или что-то подобное). Я получаю следую...
6 месяцев назад Hugh Rawlinson
89
голосов
1
ответ
Это моя Грейдл: apply plugin: 'com.android.application' android { compileSdkVersion 21 buildToolsVersion "21.1.2" defaultConfig { applicationId "com.googleplus_1" minSdkVersion 10 targetSdkVersion ...
6 месяцев назад Green Apple
69
голосов
1
ответ
Из ниоткуда мой проект Android Studio начал давать мне эту ошибку: запись ресурса com.crashlytics.android.build_id уже определена. Я видел такой же вопрос, как здесь, на SO, но решение для меня не ...
6 месяцев назад ebenstea13
71
голос
1
ответ
Спасибо за совет, в документе говорится: TextResource ruleSetConfig Note: This property is incubating and may change in a future version of Gradle. The custom rule set to be used (if any). Replaces...
6 месяцев назад Caipivara
89
голосов
1
ответ
Поскольку обновление моего градиента от 2.2.3 до 3.0.1, сбор данных генерирует класс BR в неправильном месте, в результате чего не удается найти класс символов BR public abstract class BaseBindingF...
6 месяцев назад IOSDev
92
голоса
4
ответа
При попытке запустить приложение на моей nexus 7, сборка gradle выполняется с ошибкой каждый раз и дает ту же ошибку: > com.android.build.api.transform.TransformException: java.util.zip.ZipExcep...
6 месяцев назад insanity_serum
57
голосов
1
ответ
Я пытаюсь создать Chromium для Android на машине Ubuntu 16.04 в качестве проекта Android Studio. Я последовал инструкциям здесь и
6 месяцев назад Sagar Joshi
89
голосов
2
ответа
У меня есть некоторые вопросы о Gradle. В чем разница между buildscript.dependencies и dependencies ? В чем разница между classpath и compile ? Что означает apply plugin: ?
6 месяцев назад Exitos
126
голосов
1
ответ
В моем Android-приложении используются ямбады Java 8: myView.setOnClickListener(view -> someMethod()); Все работает отлично с приведенным выше при построении приложения или при проведении модуль...
6 месяцев назад ADev
89
голосов
1
ответ
Я импортировал свой проект в Android Studio 1.3.2 , и теперь он показывает ошибку Gradle sync started Gradle sync failed: Argument for @NotNull parameter 'aFileName' of com/intellij/openapi/util/io...
6 месяцев назад Aditya Vyas-Lakhan
59
голосов
2
ответа
введите описание изображения здесь Я новичок в Android. Пожалуйста, поделитесь этим решением. Я установил андроид-студию, тогда я получаю ниже ошибки в консоли Gradle, когда я скомпилировал свою пр...
6 месяцев назад Keerthana
70
голосов
2
ответа
Я не уверен, где правильно помещать локальные свойства для проекта (путь файла в этом случае) для проекта Android Studio, построенного с помощью gradle: local.properties: Это будет то, что мне нужн...
6 месяцев назад Display name
69
голосов
1
ответ
Я получаю эту ошибку при попытке запустить приложение на устройстве. Однако синхронизация града всегда успешна. Ошибка: выполнение выполнено для задачи: EmployeeManager: transformClassesWithJarMerg...
6 месяцев назад Manu Ram V
80
голосов
1
ответ
Я загрузил одно приложение для Android из Интернета, когда я открываю его, я получил ошибки, как показано ниже. Как я могу это решить, пожалуйста, помогите мне [![apply plugin: 'com.android.applica...
6 месяцев назад Krish
172
голоса
8
ответов
Приложение падает, когда я применяю к нему crashlytics FATAL EXCEPTION: main Process: com.ehs.pk, PID: 20963 java.lang.RuntimeException: Unable to get provider com.crashlytics.android.CrashlyticsIn...
6 месяцев назад Amir Jehangir
89
голосов
1
ответ
Я привязал все зависимости от градиента моего приложения (что, по моему мнению, является причиной замедления приложения). Скажите, пожалуйста, если какая-либо из зависимостей может быть заменена бо...
6 месяцев назад Neeraj Athalye
89
голосов
1
ответ
После добавления тестовых файлов Espresso я получил ошибку. Я пробовал много предложений, пока ничего не помогло. НЕОПРЕДЕЛЕННЫЙ ТОП-УРОВЕНЬ EXCEPTION: com.android.dex.DexException: несколько файло...
6 месяцев назад tjm1706
57
голосов
1
ответ
Я хочу использовать сильную версию 4.4-градусной версии Есть ли для этого решение? Я ищу решение долгое время, но не смог его найти Минимальная поддерживаемая версия Gradle - 4.6. Текущая версия - ...
6 месяцев назад Kishore Jethava
57
голосов
1
ответ
Я работаю над своим первым Android-приложением. Он предназначен для погружения и скрывает навигационную панель во всех действиях, обеспечивая при этом собственную внутреннюю навигацию через ActionB...
6 месяцев назад j.h.
-4
голоса
2
ответа
Я новичок в андроиде. Я только что закончил загрузку андроид-студии, и теперь я настраиваю настройку gradle. Я думаю, что град отсутствует или мой компьютер еще не видел его. Я не уверен и не знаю,...
6 месяцев назад Tukta
154
голоса
4
ответа
Ошибка: не удается настроить расширение публикации после его доступа. Я получаю эту ошибку после обновления моей студии Android. это мой app.gradle apply plugin: 'com.android.application' android {...
6 месяцев назад user6076314
57
голосов
1
ответ
У меня 4 типа сборки в Android Studio: release debug kindle kindle_debug Как можно задавать задачи обоих типов для использования одних и тех же данных из release/debug и просто изменять некоторые с...
6 месяцев назад mars3142
57
голосов
1
ответ
Где стандартная установка Android Studio под Linux добавляет исполняемый файл gradle? Я хочу запустить его из строки cmd, но не могу найти его для добавления в мой PATH
6 месяцев назад bph
108
голосов
1
ответ
У меня есть один SDK, который имеет зависимость от модуля ниже: compile 'com.google.android.gms:play-services-tapandpay:16.0.2' При сборке выдает следующее сообщение об ошибке: ERROR: Failed to res...
6 месяцев назад mayur
91
голос
1
ответ
Я столкнулся с проблемой ниже. У меня есть три проекта. Я называю их проектами A, B и lib Project Lib -> androidTest -> utilityfile.kt Project A -> androidTest -> <use utilityfile.kt...
6 месяцев назад Hardik Trivedi
57
голосов
1
ответ
Я пытаюсь интегрировать проект ndk в моем приложении. Это хорошо в eclipse.in Android Studio, давая ошибку. C:\Android\sample\app\src\main\jni\libogg\bitwise.c:24:21: fatal error: ogg/ogg.h: No suc...
6 месяцев назад Asthme
184
голоса
11
ответов
В Android Studio я просто создал новый проект, и он говорит, что: Gradle project sync failed. Basic functionality will not work properly. Я искал в Интернете и пробовал все, но ничего не получилось...
6 месяцев назад vcapra1
57
голосов
1
ответ
Сегодня я, как обычно, открыл свой проект и обнаружил, что мой проект не был синхронизирован с файлами Gradle, и опция синхронизации проекта с файлами Gradle отключена. Эта проблема появилась дважд...
6 месяцев назад jackz314
57
голосов
1
ответ
Я просто установил последнюю версию Android SDK, но мой проект был сделан в старой версии Это мой код: Это ошибка, которая отображается в моем журнале событий: <
6 месяцев назад Nelson Rolando Rodriguez Herna
57
голосов
1
ответ
Я тестировал приложение для Android на телефоне с Android 5.1.1, и все работает нормально, но сегодня я тестировал его на планшете с Android 5.0.2, и я получаю следующее предупреждение, и приложени...
6 месяцев назад Tuco
80
голосов
2
ответа
Я начал с изучения пары Гистов, которую я нашел в Github: https://gist.github.com/lpetre/87a5196d14cf4484f1f2 И это отлично работает на моем ноутбуке, однако я пытаюсь настроить Travis-CI для автом...
6 месяцев назад Adam
169
голосов
9
ответов
Каковы некоторые плюсы и минусы, добавляющие зависимости в build.gradle , вместо добавления их в качестве зависимых библиотек? dependencies { compile project(':library') ... compile 'com.stackoverf...
6 месяцев назад melvynkim
98
голосов
2
ответа
Я пытаюсь обновить версию служб Google с 3.1.0 до 4.2.0. корень build.gradle{ buildscript{ repositories { google() jcenter() } dependencies { classpath 'com.google.gms:google-services:4.2.0' } } } ...
6 месяцев назад LonsomeHell
57
голосов
1
ответ
У меня есть проект, содержащий сервер и приложение для Android, сервер основан на Java. Я хочу создать модуль градиента для обычного java-кода, который может использоваться сервером и Android-прило...
6 месяцев назад jacob
99
голосов
1
ответ
У меня есть два приложения для Android, на которые я смотрю - тот, который я создал некоторое время назад, и еще одно, что я сейчас делаю. Когда я пытаюсь скомпилировать новую, я получаю сообщение ...
6 месяцев назад joelt
57
голосов
2
ответа
Я использую android studio, и я пытаюсь добавить baseGamesUtils из github в игру, которую я сделал, чтобы добавить таблицы лидеров. Следуя учебному курсу на сайте разработчика googles, я загрузил и...
6 месяцев назад trynelaidd
70
голосов
2
ответа
Я хотел бы создать библиотеку Android, включая другие библиотеки. У меня есть 2 рабочих пространства: /workspace1 /libA /myLib /workspace2 /myApp Андроидная библиотека myLib зависит от libA. Андрои...
6 месяцев назад persa
Чтобы , пожалуйста,
Выберите тему жалобы:

Другая проблема